网站升级到Zibll主题 V7.5.1版本后新用户无法注册报错500

这两天的网站受到了主题升级到Zibll主题 V7.5.1版本的困扰,因为自己使用没问题,但无法注册新用户,用户注册时能收到邮箱验证码,但提交注册时网页返回500error,让我刷新网页后重试,但刷新无数次也不能成功注册。

图片[1]-网站升级到Zibll主题 V7.5.1版本后新用户无法注册报错500-墨铺

在子比官方群里面求助的时候,很崩溃的竟然没有得到任何反馈,老唐有时候也很不靠谱,可能一个群里面的也没有遇到这类事的。

一开始我以为是服务器的问题,进服务器重启了机子,也试过把Nginx、php等软件重启,甚至想对这些软件进行升级,因为我猜测是不是Zibll主题 V7.5.1版本需要更新版本支持的原因,但都搞不定这个问题。

今天终于让我无意中找到了问题所在,我先是启用另一套主题,发现注册是正常的,那么我想这只能是主题的问题了,而在我的一个站点其注册也是正常的,同服务器的另一站点注册却不正常,同样的LNMP环境为什么一个正常一个不正常呢?他们都是Zibll主题 V7.5.1版本,这时候就想到检查一下WordPress版本了,然后就发现注册正常的这个网站使用的是WordPress 6.4.1版本,而另几个网站我一直没做wp版本的升级。

至此解决网站升级到Zibll主题 V7.5.1版本后新用户无法注册报错500这个问题的方法就是:网站升级到WordPress 6.4.1版本吧!

图片[2]-网站升级到Zibll主题 V7.5.1版本后新用户无法注册报错500-墨铺

升级WordPress版本,可以从右上角的升级按钮处进,有些网站是屏蔽掉这个按钮的,那么就鼠标停留在仪表盘上面,会出现“更新”入口。

升级一般是很快的,有时升级后会提示需要升级数据库,点击确认就成功了。

图片[3]-网站升级到Zibll主题 V7.5.1版本后新用户无法注册报错500-墨铺

本次故障的原因就是Zibll主题 V7.5.1需要WordPress 6.4.1版本的支持。

图片[4]-网站升级到Zibll主题 V7.5.1版本后新用户无法注册报错500-墨铺

 

© 版权声明
THE END
喜欢请点赞支持!
点赞8 分享